Saturday, 15 December 2012

KBarcode-kde4 port ready and released

KBarcode has been ported to KDE4/Qt4 by Fanda. Also some of the older bugs related to GUI have been fixed. It seems stable. The new version of KBarcode for KDE4/Qt4 has been renamed to KBarcode-kde4 so that users can have the old KBarcode for KDE3/Qt3 as well as the new KBarcode for KDE4/Qt4 installed on one system.

KBarcode-kde4 uses Akonadi. KCommand and related stuff has been ported to QUndoCommand and so on ... Spellchecking was ported to Sonnet but the new implementation of Sonnet in KBarcode-kde4 is odd and complicated so it will be deprecated and replaced in a future version.

KBarcode-kde4 is currently in a beta stage. It is not in Ubuntu or Debian repositories yet. At the moment (2012-12-14) only a deb package for amd64 architecture exists. Download the deb package kbarcode-kde4_3.0.0b2-1_amd64.deb from https://sourceforge.net/projects/kbarcode/files/Development/3.0.0b2/kbarcode-kde4_3.0.0b2-1_amd64.deb and follow instructions in https://sourceforge.net/projects/kbarcode/files/Development/3.0.0b2/README-INSTALL.txt to install it.

The source code can be found in the source tarball at http://sourceforge.net/projects/kbarcode/files/Development/3.0.0b2/kbarcode-kde4_3.0.0b2.tar.gz/download or in the GIT repository at https://gitorious.org/kbarcode-kde4/kbarcode-kde4/commits/master.

Thank you very much for your work Fanda!

4 comments:

jstaniek said...

Is libprison used?

Dominik Seichter said...

I think it is still based on GNU Barcode and Ghostscript. Libprison would be a major improvement, though. Maybe you want to suggest it to Fanda or over the kbarcode mailinglist ?

jstaniek said...

@Dominik feel free to discuss on the list and contact the author. I see it surprising that "the" KDE barcode library is not used by "the" KDE barocode tool.

I wonder - is Akonadi hard dependency and if so - why (I see no relation for this lack of modularity).

Jeremy said...

I was wondering what it would take to get kbarcode ported to newer versions of Ubuntu. Thanks for the help!